Yamaha YZF-R7 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Alright so watching the latest motonosity youtube video on the R7 has lead me to this upgrade “Rapid Bike EVO Auto Tuning Fuel Management Tuning Module Yamaha / YZF-R7 / 2022”. Anyone have any experience with this? I have a stage two intake from DNA waiting to be installed so I’m hoping this is enough to install it since it updates as you ride instead of flashing the ECU
 

·
Registered
Joined
·
93 Posts
You have to save the changes as well though yes it tune as you ride but doesn’t save the chances if reverts back to base map when you turn the bike off. If I remember correctly(could be wrong) it’s been while since used rapid bike it’s a good product with good customer support. Call him up and he will get you hooked up with all your questions and needs. I had it on a 675 and the timing was off on their base line map and he remote connected to it and got it all set up for me and ran me through the basics of it with launch and traction control (I had the race model)
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·

Just a little update, I had a little trouble installing the unit from motovation but in the end it all worked out. So originally, I installed the unit with a little help from the dynojet power commander pictures and basic knowledge where the o2 sensor coupler was (right side of bike behind the metal 3 bolt fairing plate above the rear set) and the rear brake light switch (tied to o2 sensor coupler) and the bike would not start. After talking to motovation I ended up plugging therapid bike into my computer and turning the bike on to figure out that the unit was not receiving 12v. So motovation sent me a picture of the R7 they installed the unit on and it turned out that two wires in the rapid bike harness were actually swapped so with a little help from a paper clip, I was able To swap the blue and red wires in the harness connector and boom, bike started and worked perfectly. Motovation was a big help with figuring out the issue and hopefully it doesn’t happen to anyone else!
 
1 - 3 of 3 Posts
Top